1. 校验插件是否最新版本

检查当前插件版本是否为最新版本。


请求方式:POST

请求地址:/api/plugins/checkVersion

1.1. 请求参数

Headers:

参数名 类型 示例 是否必填 参数含义
NULL NULL NULL NULL NULL

PathParas:

参数名 类型 示例 是否必填 参数含义
NULL NULL NULL NULL NULL

SearchParas:

参数名 类型 示例 是否必填 参数含义
无参数 NULL NULL NULL NULL

Body

application/json:

{
    "type":"插件类型", //必传
    "version":"当前插件版本" //必传
}

1.2. 参数说明

参数名 类型 示例 是否必填 参数含义
type string NULL 插件类型
version string NULL 当前插件版本

1.3. 正确返回

{
    "message": "请求处理成功",
    "code": "SUCCESS",
    "data": {
        "version": "xxxx",
        "url": "xxxx",
        "updates": "xxxx",
        "updateDate": "xxxx"
    }
}

1.4. 状态码

状态码 code message data 原因
400 BAD_PARAMETER_VALUE 参数(type)值不正确 NULL 当不存在类型为(" type")的插件信息
400 BAD_PARAMETER_FORMAT 参数(version)格式不正确 NULL 当参数version格式不正确时

1.5. 备注

暂无备注

1.6. 注意事项

返回最新版插件信息。

版权所有@盈嘉互联(北京)科技有限公司 京ICP备15051988号-9 Copyright © 2021 all right reserved,powered by Gitbook该文件修订时间: 2021-08-25 16:16:24

results matching ""

    No results matching ""